Autor Tema: Problemas con las "cookies" en conexión por VPN  (Leído 6014 veces)

Manolo

  • Bimilenari@
  • **
  • Mensajes: 2876
  • No dejes que la realidad te arruine una buena foto
    • Mi galeria en Ipernity
Problemas con las "cookies" en conexión por VPN
« on: 05 jul 2013, 13:20 pm »
Desde que me conecto al foro con la tableta, tengo algunos problemas con el foro. Realmente, el problema viene por conectarme a través de una red privada virtual (VPN), que es un recurso que utilizo principalmente en la tableta cuando me conecto desde una WiFi que no conozco (por ejemplo, desde un hotel); no me gusta que espíen mi tráfico (especialmente las contraseñas...)

Descripción del problema: estoy navegando correctamente por el foro, identificado de forma "permanente". Me conecto a una VPN y vuelvo al foro. En ese momento me avisa de que mi usuario no está autorizado a visualizar el contenido del foro. Me desconecto de la VPN y vuelvo. Exactamente el mismo mensaje. Además, estoy "fuera" de mi perfil. La única solución es borrar las "cookies", pero como aún no sé borrar "cookies" individuales con el "chrome" de la tableta, tengo que borrar todas, con lo que me saca del perfil de otros foros, en los que tengo que volver a "loguearme".

Variaciones del mismo tema: he probado salir del perfil ANTES de conectarme a la VPN. Me ocurre lo mismo, sólo que el mensaje cambia a "invitado no tiene permiso de ver este foro" o algo así.

Con otros foros tipo SMF, vBulletin y demás, el único problema que tengo es que tras conectarme a la VPN, el foro deja de reconocerme como ingresado (me echa del perfil), pero puedo seguir leyendo mensajes.

Es decir, el foro de fotolibre es especialmente quisquilloso con las "cookies" y, ademas de echarte del perfil, ¡prohibe la navegación!

¿Es normal que ocurra esto? ¿algún parámetro de configuración histórico que no se ha revisado en los últimos cambios?  :??
« Última Modificación: 05 jul 2013, 13:52 pm por Manolo »
Ubuntu & Debian, Nikon D40X Nikon D5100
ufraw, photivo, imagemagick, gimp, pantools
Artículos y fotos bajo licencia CC-BY

Colegota

  • Palizas oficial
  • *
  • Mensajes: 8177
  • ¡Me faltan carretes!
    • ¡Me faltan carretes!
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #1 on: 05 jul 2013, 14:12 pm »
Con otros foros tipo SMF,

Este foro es un SMF.

Es decir, el foro de fotolibre es especialmente quisquilloso con las "cookies" y, ademas de echarte del perfil, ¡prohibe la navegación!

¿Seguro que esa frase está bien redactada? ¿No será algún problema de experimentos raros con un navegador privativo que te espía? ¿Tiene sentido usar una VPN y navegar con Chrome? ¿usas la VPN porque quieres asegurarte de que sólo te espíe Google? :-o

SMF, y por tanto este foro, pone una cookie normal y corriente. No se qué problema puede haber pero no parece dar problemas en entornos "normales". Probablemente tengas mal configurado algo en las capas que le añades a la navegación pero no puedo averiguarlo con tan poca información y si fuera algo del foro daría también el problema en navegación normal.

[Canon EOS 50 40D (sin diapos ni nada)] [Escáner Minolta DSE 5400] [Vuescan] [El GIMP] [Galería] [Página de Viajes]

Manolo

  • Bimilenari@
  • **
  • Mensajes: 2876
  • No dejes que la realidad te arruine una buena foto
    • Mi galeria en Ipernity
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #2 on: 05 jul 2013, 14:31 pm »
Con otros foros tipo SMF,

Este foro es un SMF.

Por eso lo cito explícitamente: en otros foros SMF no ocurre esto.

Es decir, el foro de fotolibre es especialmente quisquilloso con las "cookies" y, ademas de echarte del perfil, ¡prohibe la navegación!

¿Seguro que esa frase está bien redactada?


Sí. Cuando aprenda a sacar pantallazos de la tableta la pongo por aquí. (**)

¿No será algún problema de experimentos raros con un navegador privativo que te espía?

Todo el sistema es privativo. Android, ya sabes. Pero creo que no van por ahí los tiros.

¿Tiene sentido usar una VPN y navegar con Chrome? ¿usas la VPN porque quieres asegurarte de que sólo te espíe Google? :-o

Ya te digo que es Android y sé lo que hay. Cuando los sistemas operativos serios tengan versión tableta funcional, me cambiaré.

Mientras tanto, soportaré su espionaje, cuyas consecuencias no son tan graves como el que un WiFi "amigo" te pille las contraseñas.

SMF, y por tanto este foro, pone una cookie normal y corriente. No se qué problema puede haber pero no parece dar problemas en entornos "normales". Probablemente tengas mal configurado algo en las capas que le añades a la navegación pero no puedo averiguarlo con tan poca información y si fuera algo del foro daría también el problema en navegación normal.


El problema también lo da en navegación normal. Creía que en eso había sido claro. Es decir:

 1) navegas por el foro tan tranquilo normalmente
 2) te conectas a la VPN.
 3) vuelves al foro
 4) ocurre la catástrofe descrita ("ud. no tiene permiso para ver este foro") (*)
 5) desconectas la VPN
 6) vuelves al foro
 7) sigue ocurriendo la catástrofe ("ud, no tiene permiso para ver este foro") (*)
 8) sigue así indefinidamente y hasta que no borras todas las cookies no se arregla

No he configurado nada raro. La navegación por otros foros es bastante más amistosa (se limita a echarte del perfil).

Gracias por estar al tanto. No creía que fuera necesario un pantallazo, pero intentaré obtenerlo y lo colgaré. (**)

(*) En concreto:

¡Un error ha ocurrido!
Lo siento Visitante, tienes el acceso denegado a este foro

(**) P.S.: ya tengo el pantallazo: http://ubuntuone.com/09QoQ9CEdpC43VvwVCbGeM
« Última Modificación: 05 jul 2013, 14:45 pm por Manolo »
Ubuntu & Debian, Nikon D40X Nikon D5100
ufraw, photivo, imagemagick, gimp, pantools
Artículos y fotos bajo licencia CC-BY

Colegota

  • Palizas oficial
  • *
  • Mensajes: 8177
  • ¡Me faltan carretes!
    • ¡Me faltan carretes!
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #3 on: 05 jul 2013, 18:11 pm »
Es decir, el foro de fotolibre es especialmente quisquilloso con las "cookies" y, ademas de echarte del perfil, ¡prohibe la navegación!
¿Seguro que esa frase está bien redactada?
Sí. Cuando aprenda a sacar pantallazos de la tableta la pongo por aquí. (**)

Me refería a que se agradecería más una redacción que suene como "Tengo un problema accediendo al foro bajo condiciones poco usuales, ¿me podéis ayudar?" que no a "Este foro es una m***** y yo lo hago todo perfecto así que a ver si lo arregláis". :ejem:

Con navegación normal me refiero a lo que hacemos el resto de los mortales. En ocho años nadie ha reportado ese error e incluso acabo de probar con las cookies deshabilitadas y funciona y te deja navegar. Este foro como sabes es un SMF, tal vez por sus foros de soporte puedas encontrar ayuda.

He visto los logs de acceso al foro pero tus entradas no aparecen como errores. Y yo más no puedo hacer salvo sugerir que pueda ser:

.- Algo en la configuración de tu tableta
.- Algo en la configuración de tu VPN
.- Algo en la configuración de tu navegador

Por cierto, no creo que ayudase mucho pero en pantallazos de estos es bueno poder ver la url a la que se intenta acceder.
[Canon EOS 50 40D (sin diapos ni nada)] [Escáner Minolta DSE 5400] [Vuescan] [El GIMP] [Galería] [Página de Viajes]

Manolo

  • Bimilenari@
  • **
  • Mensajes: 2876
  • No dejes que la realidad te arruine una buena foto
    • Mi galeria en Ipernity
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #4 on: 05 jul 2013, 20:01 pm »
Es decir, el foro de fotolibre es especialmente quisquilloso con las "cookies" y, ademas de echarte del perfil, ¡prohibe la navegación!
¿Seguro que esa frase está bien redactada?
Sí. Cuando aprenda a sacar pantallazos de la tableta la pongo por aquí. (**)

Me refería a que se agradecería más una redacción que suene como "Tengo un problema accediendo al foro bajo condiciones poco usuales, ¿me podéis ayudar?" que no a "Este foro es una m***** y yo lo hago todo perfecto así que a ver si lo arregláis". :ejem:

¿¡ De verdad ha sonado así !?  :-o Pues no era mi intención  :sesiente: Y por más que releo mi mensaje original no pillo ese matiz.

Quería enfatizar lo del comportamiento de otros foros (eso de que te echa de tu perfil) por si podía dar una pista. A lo mejor es lo que ha sonado despectivo. Pero nada más lejos de mi intención.

Justamente esa diferencia de comportamiento es lo que me ha decidido a levantar esta incidencia.


He visto los logs de acceso al foro pero tus entradas no aparecen como errores. Y yo más no puedo hacer salvo sugerir que pueda ser:

.- Algo en la configuración de tu tableta
.- Algo en la configuración de tu VPN
.- Algo en la configuración de tu navegador

Por cierto, no creo que ayudase mucho pero en pantallazos de estos es bueno poder ver la url a la que se intenta acceder.


¡Perdón! Es la de inicio: http://comunidad.fotolibre.net/index.php

Por mi parte sigo investigando el problema. He probado a conectarme por VPN desde un ordenador "normal" con S.O. "normal" y firefox y no noto nada raro por ahora. (*)

Voy a probar desde la tableta usando un navegador distinto al de la casa. ¿Alguna sugerencia de navegador para instalar? (firefox parece un poco "pesado" para una tableta)

(*) P.S. La IP que da la VPN es 93.115.82.54. Me he conectado alrededor de medianoche entre el 5 y 6 de julio. Por si ayuda.
« Última Modificación: 05 jul 2013, 20:06 pm por Manolo »
Ubuntu & Debian, Nikon D40X Nikon D5100
ufraw, photivo, imagemagick, gimp, pantools
Artículos y fotos bajo licencia CC-BY

Colegota

  • Palizas oficial
  • *
  • Mensajes: 8177
  • ¡Me faltan carretes!
    • ¡Me faltan carretes!
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #5 on: 06 jul 2013, 03:47 am »
¡Perdón! Es la de inicio: http://comunidad.fotolibre.net/index.php

Era por si llevaba algún parámetro adicional en la url, pero entiendo que no.

Por mi parte sigo investigando el problema. He probado a conectarme por VPN desde un ordenador "normal" con S.O. "normal" y firefox y no noto nada raro por ahora. (*)

Voy a probar desde la tableta usando un navegador distinto al de la casa. ¿Alguna sugerencia de navegador para instalar? (firefox parece un poco "pesado" para una tableta)

En el teléfono apenas navego y aunque como dices es pesado, uso Firefox. Prefiero apoyarlo y sobre todo prefiero no usar Chorme porque cuanto más leo de él y de Google más me pregunto qué estamos haciendo. Espero subiros pronto la documentación de mi charla anterior sobre privacidad y solo con ver los enlaces de las referencias se te quitan las ganas de muchas cosas.

Cuando las versiones de Firefox eran mucho más inusables que las de ahora usaba Dolphin Browser. También privativo, pero como es nuevo le costará llegar a los niveles de seguimiento y minería de datos de Google y esperemos que Firefox avance un poco más o salgan alternativas libres. De todas formas, las últimas veces parece que Firefox corre mejor.

(*) P.S. La IP que da la VPN es 93.115.82.54. Me he conectado alrededor de medianoche entre el 5 y 6 de julio. Por si ayuda.

Esa tampoco tiene entradas como errores en el log.
[Canon EOS 50 40D (sin diapos ni nada)] [Escáner Minolta DSE 5400] [Vuescan] [El GIMP] [Galería] [Página de Viajes]

Manolo

  • Bimilenari@
  • **
  • Mensajes: 2876
  • No dejes que la realidad te arruine una buena foto
    • Mi galeria en Ipernity
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #6 on: 06 jul 2013, 08:17 am »
¡Perdón! Es la de inicio: http://comunidad.fotolibre.net/index.php

Era por si llevaba algún parámetro adicional en la url, pero entiendo que no.


No, no lo tiene.

Pero he observado algo curioso: cuando navegas por el foro fuera del perfil (es decir, una vez "reseteada" la obstrucción esa de la que estamos hablando), las URL de cada hilo llevan una coletilla que dice algo así como "PHPSSID=blablabal..."

Eso sólo lo he observado en la tableta. Cuando me salgo del perfil en un ordenador normal y navego por los distintos hilos no hay nada de eso.

Puedes probarlo tú mismo: te conectas desde el móvil al foro; si estuvieras ingresado, te sales; vas navegando por hilos y observas la barra de direcciones. A ver si eso ayuda...

En el teléfono apenas navego y aunque como dices es pesado, uso Firefox.

Al final te he hecho caso y he instalado Firefox. Será muy pesado, pero es tremendamente manejable  :-) Me ha sorprendido positivamente.

Pero el caso es que en lo relativo a esta incidencia el diagnóstico es exactamente el mismo. Y también se ven esas coletillas "PHPSSID..." cuando navegas fuera del perfil.

He instalado un tercer navegador, "Lightening". Exactamente el mismo diagnóstico.
Ubuntu & Debian, Nikon D40X Nikon D5100
ufraw, photivo, imagemagick, gimp, pantools
Artículos y fotos bajo licencia CC-BY

elpecoso

  • Milenari@
  • *
  • Mensajes: 1466
  • Esto es lo que somos
    • La madriguera del escobrice
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #7 on: 06 jul 2013, 13:49 pm »
Lo del phpssid es el identificador de sesion. Es una variable en la url que se usa habitalmente.
Manolo,  si puedes prueba a seleccionar en el navegador la opcion "Ver como en un ordenador" a ver si sacamos algo.
Aunque si te digo la verdad, pa mi que es algo de la vpn. Proxy, encriptacion, etc.
Por cierto, cuenta como tienes montada la vpn que con lo que viajo ahora, es un tema que me interesa mucho. Ahora cuando tengo que hacer algun tema de administracion o algo sensible, lo hago haciendo compartiendo la conexion del movil.
Chau!
Me gustaría cambiar el mundo, pero no me dan el código fuente
<- La ultima de La madriguera del escobrice

elpecoso

  • Milenari@
  • *
  • Mensajes: 1466
  • Esto es lo que somos
    • La madriguera del escobrice
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #8 on: 06 jul 2013, 13:50 pm »
Por cierto, para el androide tambien tienes Opera.
Chau!
Me gustaría cambiar el mundo, pero no me dan el código fuente
<- La ultima de La madriguera del escobrice

Colegota

  • Palizas oficial
  • *
  • Mensajes: 8177
  • ¡Me faltan carretes!
    • ¡Me faltan carretes!
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #9 on: 06 jul 2013, 16:24 pm »
He estado navegando desde el móvil y aparte de la variable de sesión no me ha pasado lo del bloqueo.

El hecho de que he estado rastreando las IP es porque ese mensaje que te da es el mismo que cuando alguien que tiene bloqueado el aceso como usuario o con su IP intenta entrar de nuevo. Pero ni tu IP habitual ni la de tu VPN están registradas. Lo único que pudiera ser es que el servidor de tu VPN estuviera en los registros de acceso, pero en ese caso no te dejaría identificarte... creo. :?

Por intentar cerrar un poco más dinos la hora exacta a la que te da el próximo bloqueo (hh:mm), y ya de paso con qué servidor te conectas al VPN y si estás en casa o si estás fuera con qué IP. Y a ser posible escribe un mensaje lo más seguido posible con tu usuario.
[Canon EOS 50 40D (sin diapos ni nada)] [Escáner Minolta DSE 5400] [Vuescan] [El GIMP] [Galería] [Página de Viajes]

Manolo

  • Bimilenari@
  • **
  • Mensajes: 2876
  • No dejes que la realidad te arruine una buena foto
    • Mi galeria en Ipernity
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #10 on: 07 jul 2013, 07:58 am »

El hecho de que he estado rastreando las IP es porque ese mensaje que te da es el mismo que cuando alguien que tiene bloqueado el aceso como usuario o con su IP intenta entrar de nuevo. Pero ni tu IP habitual ni la de tu VPN están registradas. Lo único que pudiera ser es que el servidor de tu VPN estuviera en los registros de acceso, pero en ese caso no te dejaría identificarte... creo. :?


Bueno, bueno... esto creo que es la pista definitiva  :-) De hecho, estaba esperando que me dijeras a qué escenarios concretos responde el mensajito de marras. Y lo del bloqueo por IP me parece que es el punto.

El servicio de VPN que uso ofrece servidores en varios países (daré más detalles en mi respuesta a el pecoso). En el portátil y bajomesa tengo sintonizado un servidor de Rumanía, que es el que usé para hacer la prueba con el bajomesa y cuya dirección IP es 93.115.82.54 Recuerdo que la prueba con el bajomesa funcionó correctamente y no se bloqueó.

Pero en la tableta tengo una "app" que el propio servicio me ofrece en su web. Esa "app" la tengo configurada por defecto para que ella misma elija el servidor más apropiado (por velocidad de conexión, disponibilidad, etc). Pues bien, acabo de hacer la prueba de obligar a la "app" a que se conecte por el servidor de Rumanía que tengo en el bajomesa y...  ¡Ha funcionado correctamente! Ya no me sale el mensajito de marras y puedo navegar ingresado en el foro sin problemas  :yahoo:

Con lo cual deduzco que el servidor (o servidores) que elegía la "app" muestran unas IP públicas que deben estar en listas negras... sólo falta hacerme con esas IP públicas e investigar qué pasa con ellas. Las pondré por este hilo, por cerrar el tema.

Muchas gracias por las pistas y por vuestro tiempo.
Ubuntu & Debian, Nikon D40X Nikon D5100
ufraw, photivo, imagemagick, gimp, pantools
Artículos y fotos bajo licencia CC-BY

Manolo

  • Bimilenari@
  • **
  • Mensajes: 2876
  • No dejes que la realidad te arruine una buena foto
    • Mi galeria en Ipernity
Re: Problemas con las "cookies" en conexión por VPN
« Respuesta #11 on: 07 jul 2013, 08:27 am »

Por cierto, cuenta como tienes montada la vpn que con lo que viajo ahora, es un tema que me interesa mucho. Ahora cuando tengo que hacer algun tema de administracion o algo sensible, lo hago haciendo compartiendo la conexion del movil.


Bueno, yo uso un servicio de pago porque los servicios gratuitos te piden (con razón) que no los uses con tráfico elevado. Es éste: https://www.privateinternetaccess.com/ Te puedes bajar un zip con la configuración de un montón de servidores, a las que les falta el usuario/contraseña que obtienes cuando te das de alta.

Si quieres probar con servicios gratuitos, hay un montón de ellos en este sitio: http://www.vpngate.net/ que es un proyecto interuniversitario. Pero es más fiable éste otro sitio gratuito (admite donaciones): http://www.vpnbook.com/

Para conectarme con GNU/Linux uso el protocolo openvpn; tienes que instalarte los paquetes oportunos; si usas un escritorio de la familia GTK (gnome, unity, xfce) estarás interesado en instalar un "plugin" de openvpn para "nm" (network manager). Todo eso viene en los repositorios habituales y no se necesita ninguna PPA especial. Todos los servicios que te he propuesto son accesibles con openvpn.

La conexión con Android no la tengo tan probada; sé que hay posibilidad de instalarte el protocolo openvpn. Pero yo sólo me conecto por ahora con privateinternetaccess y para eso uso una "app" que te puedes descargar desde el mismo sitio.

Si tienes alguna duda concreta pregunta.  :??
Ubuntu & Debian, Nikon D40X Nikon D5100
ufraw, photivo, imagemagick, gimp, pantools
Artículos y fotos bajo licencia CC-BY