Autor Tema: Me faltan script-fus en mi nueva versión del GIMP.  (Leído 9683 veces)

Colegota

  • Palizas oficial
  • *
  • Mensajes: 8180
  • ¡Me faltan carretes!
    • ¡Me faltan carretes!
Me faltan script-fus en mi nueva versión del GIMP.
« on: 18 abr 2007, 08:47 am »
Buenas,

pues resulta que como ya he comentado, para enfocar yo utilizaba un scrip-fu llamado unsharp-mask y traducido como Máscara de desenfoque o Desafilar máscara según las traducciones. Es decir, no confundir con el de Filtros->Realzar->Máscara de desenfoque. Este debería estar en Script-fu->Alquemy(o Alquimia).

El caso es que investigando un poco he visto que mi actual versión 2.3.10 (Mandriva 2007) tiene dos directorios para scripts (y carpetas en general),
/usr/share/gimp/2.0/scripts/
/home/colegota/.gimp-2.3/scripts

Los de la primera no me aparecen en el menú de script-fu. De hecho, sólo me aparecen los que había ido bajándome yo y que estaban en la segunda.
Aparecen sin embargo en el menú Ext de la ventana principal del GIMP (no en la de las imágenes).
El unsharp-mask.scm está en la primera carpeta, pero ni aparece en Ext ni me aparece en script-fu si lo copio a la segunda carpeta.

¿Alguien me puede "iluminar"?

Saludos,
Colegota

[Canon EOS 50 40D (sin diapos ni nada)] [Escáner Minolta DSE 5400] [Vuescan] [El GIMP] [Galería] [Página de Viajes]

Wesker 'NeV3rKilL'

  • Habitual
  • ***
  • Mensajes: 60
  • El mundo cambia, las fotos no.
    • NeV3rKilL's Site (Generalmente Off)
Re: Me faltan script-fus en mi nueva versión del GIMP.
« Respuesta #1 on: 18 abr 2007, 19:19 pm »
La verdad es que no lo sé. Solo recuerda que 2.3 es CVS y que no es una version. A mi por ejemplo en las selecciones no me salen las hormiguitas y he de trabajarlo todo con capas de mascara.

Sólo sé que no sé nada. (Socrates)

enr

  • Comenzando
  • *
  • Mensajes: 9
Re: Me faltan script-fus en mi nueva versión del GIMP.
« Respuesta #2 on: 19 abr 2007, 05:23 am »
Hola,

No soy un experto en este tema, pero los "scripts-fu" yo los he copiado siempre en la segunda carpeta:

Cita
/home/colegota/.gimp-2.3/scripts

De esta manera siempre me ha funcionado...  ;)

redy

  • Moderador
  • Bimilenari@
  • *****
  • Mensajes: 2897
  • Gnudista
    • Esteropes El Cíclope
Re: Me faltan script-fus en mi nueva versión del GIMP.
« Respuesta #3 on: 19 abr 2007, 07:05 am »

¿Alguien me puede "iluminar"?


En el menú Archivo -> Preferencias -> Carpetas -> Scripts puedes ver de dónde lee gimp los scripts y quitar o añadir carpetas si quieres.

Por cierto el gimp 2.3 hace algunas cosas raras con algunos scripts que funcionan bien en 2.2 (2.3 es una versión de desarrollo que irá camino de convertirse en 2.4 que será estable). Concretamente el filtro 'Unsharp mask' tiene un bug ya resuelto en las últimas versiones http://bugzilla.gnome.org/show_bug.cgi?id=325007 supongo que el script del que hablas llama al plugin...

En cualquier caso, muchos plugins han cambiado de sitio en gimp 2.3, para localizar dónde están, elige 'Examinador de complementos' en el menú 'Ext' de la ventana principal y dale a buscar por una palabra que conozcas de su título, en tu caso puedes usar por ejemplo 'unsharp' te lo buscará y te indicará el menú en que se encuentra, así como una descripción de lo que hace y que parámetros necesita, entre otras cosas.

A lo peor es que no lo carga porque no le cuadra algun parámetro, lanza el gimp desde una consola y mira si da algun mensaje de error de que no puede cargar algun script....

Admiro a la gente que sabe contar historias solamente con sus fotos, porque en el fondo las fotos son como los chistes; si tienes que explicarlas es que no son buenas...


Colegota

  • Palizas oficial
  • *
  • Mensajes: 8180
  • ¡Me faltan carretes!
    • ¡Me faltan carretes!
Re: Me faltan script-fus en mi nueva versión del GIMP.
« Respuesta #4 on: 19 abr 2007, 08:48 am »
Buenas,


En el menú Archivo -> Preferencias -> Carpetas -> Scripts puedes ver de dónde lee gimp los scripts y quitar o añadir carpetas si quieres.

Sip, de ahí saqué las carpetas que estaba usando.

Cita
Por cierto el gimp 2.3 hace algunas cosas raras con algunos scripts que funcionan bien en 2.2 (2.3 es una versión de desarrollo que irá camino de convertirse en 2.4 que será estable). Concretamente el filtro 'Unsharp mask' tiene un bug ya resuelto en las últimas versiones http://bugzilla.gnome.org/show_bug.cgi?id=325007 supongo que el script del que hablas llama al plugin...

Nop, el que yo uso es script-fu-unsharp-mask.scm que no tiene que ver con el unsharp-mask "a secas". Se trata de que crea una máscara de enfoque para las sombras, otra para las luces y las combina por transparencia. Ese método lo describe también un autor de libros sobre PS muy famoso que ahora no recuerdo el nombre.
Sobre todo, es que es muy sencillo y creo que eficaz, además de que enfoca sin grano. El del radio, etc. nunca he conseguido entenderlo. :(

Yo tenía originalmente en mi pc una 2.0 que actualicé a 2.2 mediante CVS en su día. Ahora, en el portátil he instlado esta que viene con la Mandriva 2007.0 (acaba de salir la 2007.1) y lo que me extraña es que hayan puesto una versión de desarrollo en una distribución estable... Puede que no funcione por la versión...

Cita
En cualquier caso, muchos plugins han cambiado de sitio en gimp 2.3, para localizar dónde están, elige 'Examinador de complementos' en el menú 'Ext' de la ventana principal y dale a buscar por una palabra que conozcas de su título, en tu caso puedes usar por ejemplo 'unsharp' te lo buscará y te indicará el menú en que se encuentra, así como una descripción de lo que hace y que parámetros necesita, entre otras cosas.

Pues no aparece. Solo está el otro, el normal unsharp mask de Filtros->Realzar.
Es curioso que hayan metido casi todos los scripts en en menú Exts ¿no? ¿O es problema en mi instalación?

Cita
A lo peor es que no lo carga porque no le cuadra algun parámetro, lanza el gimp desde una consola y mira si da algun mensaje de error de que no puede cargar algun script....

Ninguno que parezca tener relación. Aunque nunca he escrito, estoy en las listas de GIMP. Tal vez pregunte ahí.

Saludos y gracias a todos,
Colegota
[Canon EOS 50 40D (sin diapos ni nada)] [Escáner Minolta DSE 5400] [Vuescan] [El GIMP] [Galería] [Página de Viajes]

redy

  • Moderador
  • Bimilenari@
  • *****
  • Mensajes: 2897
  • Gnudista
    • Esteropes El Cíclope
Re: Me faltan script-fus en mi nueva versión del GIMP.
« Respuesta #5 on: 19 abr 2007, 18:36 pm »

Pues no aparece. Solo está el otro, el normal unsharp mask de Filtros->Realzar.


Estoy en casa delante de una mandriva y el script en cuestión está mal (Bueno supongo que esta mal para gimp 2.3 pero igual en el 2.2 funcionaba bien. Editalo y al final de todo, dónde pone....

Código: [Seleccionar]
(script-fu-register "script-fu-unsharp-mask"

.... cambia la siguiente línea por algo como:

Código: [Seleccionar]
"<Image>/Script-Fu/Alchemy/Unsharp Mask"

(O el equivalente al menú donde quieras que aparezca el script en cuestión)

(Modificado) No sé si me expliqué bien: debe quedar tal que así:

Código: [Seleccionar]
(script-fu-register "script-fu-unsharp-mask"
                    "<Image>/Script-Fu/Alchemy/Unsharp Mask"
                    "Make a sharp image of IMAGE's DRAWABLE by applying unsharp
                    "Shuji Narazaki <narazaki@gimp.org>"
                    "Shuji Narazaki"
                    "1997,1998"
                    ""
                    SF-IMAGE       "Image"             0
                    SF-DRAWABLE    "Drawable to apply" 0
                    SF-ADJUSTMENT _"Mask size"         '(5 1 100 1 1 0 1)
                    SF-ADJUSTMENT _"Mask opacity"      '(50 0 100 1 1 0 1))


« Última Modificación: 19 abr 2007, 18:46 pm por redy »
Admiro a la gente que sabe contar historias solamente con sus fotos, porque en el fondo las fotos son como los chistes; si tienes que explicarlas es que no son buenas...


Colegota

  • Palizas oficial
  • *
  • Mensajes: 8180
  • ¡Me faltan carretes!
    • ¡Me faltan carretes!
Re: Me faltan script-fus en mi nueva versión del GIMP.
« Respuesta #6 on: 19 abr 2007, 21:45 pm »
Buenas,

gracias Redy, pero no funciona. :(
He hecho el cambio pero nada. Y por la consola no sale nada.


¡¡¡Gracias Redy pero sí funciona!!!  ;D ;D ;D
Lo había cambiado en la versión de la carpeta de mi home, pero luego he probado a cambiarlo en /usr/share/gimp/2.0/scripts y ahí sí que ha funcionado.
Probablemente porque está puesta esa carpeta la primera en las preferencias y al fallar ahí ya no tenían efecto los cambios después.

Bueno, que me has dado una alegría que uno ya no tiene edad para aprender "radios" de esos. ;) Te debo unas cuantas cervezas o lo que quieras. :)

Saludos,
Colegota
[Canon EOS 50 40D (sin diapos ni nada)] [Escáner Minolta DSE 5400] [Vuescan] [El GIMP] [Galería] [Página de Viajes]

redy

  • Moderador
  • Bimilenari@
  • *****
  • Mensajes: 2897
  • Gnudista
    • Esteropes El Cíclope
Re: Me faltan script-fus en mi nueva versión del GIMP.
« Respuesta #7 on: 20 abr 2007, 04:11 am »

Lo había cambiado en la versión de la carpeta de mi home, pero luego he probado a cambiarlo en /usr/share/gimp/2.0/scripts y ahí sí que ha funcionado.
Probablemente porque está puesta esa carpeta la primera en las preferencias y al fallar ahí ya no tenían efecto los cambios después.


Si. Los scripts y los plugins se cargan por el órden en que están las carpetas y si hay duplicidades solo se carga el primero. Esto puede dar como resultado que si actualizamos un plugin en la carpeta de usuario que ya estaba en la del sistema con una versión más antigua, solo se carga la antigua (hay que tener ojo con esto).
Admiro a la gente que sabe contar historias solamente con sus fotos, porque en el fondo las fotos son como los chistes; si tienes que explicarlas es que no son buenas...


Colegota

  • Palizas oficial
  • *
  • Mensajes: 8180
  • ¡Me faltan carretes!
    • ¡Me faltan carretes!
Re: Me faltan script-fus en mi nueva versión del GIMP.
« Respuesta #8 on: 13 abr 2008, 17:21 pm »
Buenas,

pues al cabo de los tiempos he conseguido que volviese a funcionar.

El caso es que me dejó de hacerlo cuando actualicé de nuevo la versión de gimp y abandoné, siguiendo con el 2.2 básicamente por este script.

Ahora tras leer el nuevo hilo que se había suscitado sobre formas de dar nitidez, haber estado a punto de hacerlo yo (el volver a sacar el tema) y darle vueltas a la cosa y a google durante un par de días, acabo de caer en la cuenta de que me pasaba lo mismo que la vez anterior. Me da la impresión de que cada vez que se hace una nueva instalación de Gimp, se vuelve a copiar el unsharp-mask.scm antiguo en /usr/share/gimp/2.0/scripts y como ese sigue mal, ya no reconoce el corregido por Redy de la carpeta de usuario (/home/colegota/.gimp-2.4/scripts).

Así que he vuelto a borrarlo de ahí (es una carpeta de root) y ya lo tengo en 2.4. No obstante, ahora me lo coloca en Filtros->Artístico a pesar de la línea
Código: [Seleccionar]
    "<Image>/Script-Fu/Alchemy/Unsharp Mask..."
¿Podéis confirmarme si tenéis el fichero unsharp-mask.scm en vuestro /usr/share/gimp...xx con la línea equivocada en la parte final?
Sobre todo los que hayáis hecho instalaciones recientes partiendo de cero.

Saludos,
Colegota
[Canon EOS 50 40D (sin diapos ni nada)] [Escáner Minolta DSE 5400] [Vuescan] [El GIMP] [Galería] [Página de Viajes]